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Course Objectives – Excel 2007 Intermediate  

At the end of this course, participants will be able to: 

 Sort data 

 Filter data 

 Work with subtotals 

 Format worksheets effectively 

 Use Conditional Formatting 

 Format multiple worksheets 

 Use the function wizard to perform additional functions 
o Payment 
o IPMT 
o PPMT 
o PV 
o FV 
o Rate 
o NPER 
o IF and Nested IF statements 

 Work with comments 

 Audit worksheets 

 Use Consolidation 

 Customize Excel‟s Default Settings 

 Create Custom Lists 

 



  Excel 2007 Intermediate 
 

Copyright  © 2008 Carlson School of Management, Office of Information Technology, University of Minnesota.   
Duplication of material without prior written consent is forbidden.  January, 2008 

Working with Data 

Excel 2007 has many convenient features for working with data and summarizing large 
worksheets.   

Subtotals 

Excel can create subtotals based upon your column headings. This can be a great way to quickly 
analyze your data.  The data sheet needs to have some common fields, e.g., month, year, division, 
state, etc. so that you can subtotal by a specific field. 

Note:  You CANNOT apply the subtotals feature to a worksheet that has been formatted as a table 
(see page 3).  You can, however, use the format as table option after applying subtotals.   

1. Sort your data first by the main column you want to use for your subtotals (e.g., Region).  

2. Click anywhere in the list you want to subtotal.  

3. From the Data tab, select Subtotals.  

 

The Subtotal dialog box displays. 
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4. Select the desired options.   Note:  To use multiple subtotals for different columns, 
deselect “Replace current subtotals.” 

5. Click OK. A screen similar to the following displays.   

 

6. If desired, click the  buttons to expand or collapse the information. (You can also 
click + or – to expand or collapse a single category of information.)  If you used multiple 
subtotals, more outline options display. 

Note: You can print this view, if desired.  

Removing Subtotals 

To remove subtotals, from the Data tab, select Subtotals. The Subtotal dialog box 

displays. Click . 

Grouping Columns or Rows 

Excel 2007 makes it easy to group data in a large worksheet to make it more manageable. 

1. Select the columns or rows you want to group. 

2. From the Data tab, select Group. 

3. The data is grouped and you are provided with  – and + buttons to expand or collapse your 

grouped data.  There are also numbered buttons in the upper-left corner of your worksheet to 
allow you to expand and collapse, depending upon how many groupings you have created.   
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Ungrouping Data 

To ungroup data, click the Ungroup button. 

Note:  You can print a grouped worksheet as displayed on your screen.   

AutoCalculate – Customize Status Bar 

You can have Excel perform a quick calculation for you.  This does not enter a result in a cell, 
but quickly displays a result for you on the Status bar. 

1. Select the range of cells you want to autocalculate.  The Status bar displays information 
for the selected cells (Average, Count, Sum). 

 

To add additional options or functions to the Status bar, right-click the Status bar and select 
the features you would like to display from the Customize Status Bar Options menu.    

Format as Table – Filters and Sorting 

A new feature of Excel 2007 is the “Format as Table” option.  This is very useful when working 
with large amounts of data.  It adds quick sort and filter tools on all column headings.  It also 
provides formatting options such as shading of alternate rows.  If you add a row or column, the 
formatting adjusts automatically to modify the shading scheme to adapt to the new content. 

1. Open the datasheet you want to format.  To use the Format as Table option, each column 
should have a heading describing the content beneath. 

2. Click anywhere in the data list. 

 

3. From the Home tab, select Format as Table. 
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The following options display.  A Table Tools context sensitive tab displays with 
formatting options.   

 

4. Select the desired format.  The following dialog box displays indicating that Excel has 
selected the entire contiguous range of data. 

 

5. Click OK.   The new format is applied with buttons to apply sorting and filtering options.  

 

Table Tools 

When you have applied a table format, the Table Tools tab displays at the top of the 
Excel screen.  Many table formatting options are available.  You can, for instance, 
apply banded column or row formatting.   

  



  Excel 2007 Intermediate 
 

Copyright © 2007, Carlson School of Management, University of Minnesota 5 

Filtering Data 

Click any of the buttons in the field headings to set filter options.  Select or deselect options to 
filter information as desired. 

 

Set the desired filter and/or sort options and click OK.  

Note:  When a filter has been applied to a column, the filter button looks like this . 

When a Sort option has been applied to a column, the filter button looks like this . 

  

Click a  to display sort and filter 
options. 
 
Set sort options. 
 
 
 
 
 
 
Select or deselect options to filter 
information as desired.  
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Sorting by More than One Column 

Follow these steps to sort by more than one column. 

1. Click the Data tab; then select Sort. 

 

The following dialog box displays. 

 

2. From the drop down box in the Column field, select the first column by which you want to 
sort, specify the Sort On, and Order options. 

3. To add another column, click Add Level; specify the Sort On and Order options.  To 

rearrange your selections, click the arrows  to modify the order in which your columns 
are sorted.   

 

4. When finished, click OK to sort your data by your specifications.  

  



  Excel 2007 Intermediate 
 

Copyright © 2007, Carlson School of Management, University of Minnesota 7 

Number Filtering 

When filtering columns containing numbers, additional filter options are available.  Click the  
for the number column you want to filter and select Number Filters.  Select the desired option. 

 

Formatting 

In addition to the Font and Number formatting that you can do from the Home tab of Excel, 
you can format worksheet protection, change alignment of cell content, and even apply 
conditional formatting.  The conditional formatting options have been greatly expanded in 
Excel 2007. 

 

Familiar formatting options are available from the buttons on the ribbon of the Home tab.  
Rest your mouse on a button to display its purpose. 

Additional options are available by clicking the  from the Font, Alignment, or Number 
galleries. „ 

  

Number
Filter 
Options 
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Formatting Borders 

You can format borders using the buttons on the Home tab, or for additional options, click the 
dropdown arrow from the Borders button and select the desired options.   

 

For additional options, click More Borders.  The following dialog box displays. 

 

1. In the Line area, select the appropriate Style and Color. 

2. In the Presets area, select the appropriate option 
or 
In the Border area, indicate the type of border you want. Verify your selections in the 
display area of the dialog box.  

3. Click OK.  
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Alignment Formatting 

You can format the alignment of the cell contents. In addition to standard horizontal 
alignments, you can also align text at an angle or vertically. The horizontal alignment is initially 
set to General. This aligns text to the left, numbers and dates to the right. Follow these steps 
to change the alignment. 

1. Select the cell(s) you want to format. 

2. From the Alignment gallery of the Home tab, select the desired options.   

 

or 

For additional options, click the  in the Alignment gallery to open the Format Cells 
dialog box.   
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3. To change horizontal formatting, in the Horizontal: field, select the appropriate options. 

 To indent text that is left aligned, select Left (Indent) from the drop down list. Then 
increase the number in the Indent: field. For each number increase, the text moves by 
how many Xs using the current font could fit in the cell to the left of the entry. 

 To fill a cell with a pattern of characters across the width of a cell (e.g. all x‟s) select 
Fill. 

 To center text across several cells, first select the cell you want to center and all other 
cells in this row over which you want the text centered. Then select Center Across 
Selection.  

4. To change the orientation or angle of the text, in the Orientation area, click and drag the 
red diamond  to the desired degree of angle.  
or 
Click to display the text vertically (one letter underneath the other). 

5. To change the vertical alignment (where the text displays vertically within the cell height), 
in the Vertical: field, select the appropriate option.  

6. To change text control, select the appropriate option. 

 Wrap text displays text on several rows in the cell while leaving the column width the 
same. 

 Shrink to fit makes the font size smaller to fit in the cell (not usually recommended). 

 Merge cells merges the contents of one cell over several selected cells.  

7. When finished selecting the appropriate options, click OK. 
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Special and Custom Number Formats 

Special Formats 

Excel has special formats for such things as Social Security numbers, phone numbers, and 
zip codes.  These formats only require that you enter the digits – no punctuation is required.  
Excel will display the numbers with punctuation in your cells.   

 

Accessing the Number Format Options  

You can access the dialog box below from the  button in the 
Number gallery.   
OR 
Right-click a cell and select Format Cells.   

Select options from the Special category. 

 

Custom Format Example – Rounding Millions 

In the following example, cell B1 has a 7 digit number that you might want to format without 
the thousands and hundreds.  One comma at the end of the format is used to display it in 
thousands. Two commas tell Excel to round to the nearest million, etc.  To create a custom 
format, you can type your format as described below.  Consult Help for other custom formats. 

When doing custom formatting, always view the Sample area to see how your number will 
display.   

1. Access the Format Cells dialog box as described above.   

2. Scroll down to Custom (left side). 
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3. In the Type field, enter the custom format as shown; then click OK. 

 To round to thousands (remove hundreds from the display in the cell), type #,#, (one 
comma at the end of each grouping). 

 To round to millions (remove hundreds and thousands from the display in the cell), 
type #,, (two commas at the end to remove two groupings). 

 

If desired, you can then use the Increase Decimal button  from the 
Home tab to display the information as 13.2 or 13.25 (million) for this example.   

 

Other Numerical Formatting Options 

Sometimes imported data displays in an undesirable format.  For instance, a date may 
display as 20080516, for May 16, 2008.  From the Data tab, select Text to Columns.  
Click Next, until you get to Step 3 of the Wizard.  Select the desired format.  (Example:  
YMD) 

Note:  You can use Text to Columns to also correct numbers entered as text. 

Note Sample 
 

Type format 
here 
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Conditional Formatting 

Excel 2007 has advanced features allowing you to format a data range quickly to see trends 
or highlight important information.   

1. Select a range of numerical data. 

2. From the Home tab of Excel, click Conditional Formatting. 

The Live preview feature allows you to see how your data will display, based upon your 
selection. Many pre-defined options are available. 

3. Select the desired option to apply the formatting.  The example below shows the Blue 
Data bar format applied to the “Jan” data.  This is similar to a chart view.  Many other 
options are available. 

 

Customizing Conditions 

To customize the conditions by which data are evaluated, set option rules using one of 
the selections circled below.   

 

Removing Conditional Formats 

To remove conditional formatting, select the desired cells; then click the Clear button

 and select Clear Formats.   



Excel 2007 Intermediate   

14 Copyright © 2007, Carlson School of Management, University of Minnesota 

Using Excel Styles for Formatting 

Excel also has styles that can be applied to your file.   

Applying an Excel Cell Style 

Select the cells you want to format; then from the Home tab, select the Cell Styles button to 
display a list of styles.  Select the desired option.   

 

Using the Format Painter 

A great way to copy formatting from one location is by using the Format 
Painter button from the Home tab of the ribbon.  

1. Select the cell(s) that have the format you want to copy. 

2. Click the Format Painter  button from the Home tab. 

3. Click and drag over the cells to which you want to copy the formatting. 

Note: To use the Format Painter for multiple locations in the worksheet, double-click the 

Format Painter button . Click and drag over the cells you want to format. To deactivate 
the Format Painter, click the button again or press your Esc key. 
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Protecting a Worksheet - Formatting Protection  

Use the Protection option to prevent valuable formulas or other data from being overwritten. If 
an entire workbook is protected, no one is able to enter any data. If you want others to be able 
to add or edit information in specific cells or ranges, when protecting a worksheet, you must 
select all cells where data should be unprotected, and “unlock” protection on those cells. 
Follow these steps to protect “selected” cells of a worksheet.   

1. Select the cells you do NOT want to protect. 

2. From the Home tab, in the Cells gallery, click Format; then click Format Cells. 

 „ 

3. If necessary, activate the Protection tab.  

 

4. De-select Locked to indicate that the selected cells can be changed. All cells not currently 
selected cannot be changed once the sheet is protected. 
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Note: You can also hide formulas.  You can use the “Hidden” option for this purpose.  
Users will only see the value displayed in the cell–the formula will not display on the 
Formula bar when the cell is selected. 

5. Click OK. 

6. To protect the worksheet, select the Review tab, then select Protect Sheet.   

 

7. In the Protect Sheet dialog box, verify that the desired options are selected.   

8. If desired, enter a password.  Please be aware that the password will be required for all 
users, so use this option with discretion. 

9. Click OK. 

Making Changes to a Protected Worksheet 

You can make changes to any unlocked cells. However, if you try to change a locked 
cell, the following prompt displays. 

 

Click OK to return to the workbook. 
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Unprotecting a Worksheet 

If you need to make changes to the locked cells, follow these steps. 

1. Select the Review tab, and select Unprotect Sheet.  

2. If prompted, enter a password, then click OK. 

Other Formatting Tips 

Numbers as Text 

To enter numbers as text, e.g., part numbers that will not be calculated, account 
numbers, invoice numbers, etc., type an apostrophe before the number.  ‟22 displays 
left aligned and would not be used in calculations. The apostrophe only displays in the 
Formula bar – not in the worksheet.  Excel now displays green triangle in the upper-left 
corner of the cell to alert you of a potential formatting problem.  Selecting the cell 

displays a  button to assist you in the changing the format, if necessary.  You can 
click the button to change to numbers if desired. 

Note:  Imported numerical data sometimes displays as text, when the desired format is 
numbers.  To change it to number format, use the button above.  The number 
formatting options won‟t change it.   

Other Numerical Formatting Options 

Sometimes imported data displays in an undesirable format.  For instance, a date may 
display as 20080516, for May 16, 2008.  From the Data tab, selecting, Text to 
Columns option may provide a solution.  

 

Click Next, until you get to Step 3 of the Wizard.  Select the desired format.  (Example:  
YMD) 

Entering Fractions 

If you want to enter fractions when typing, you must type a zero, then a space, then the 
fraction, e.g., 0 3/5.  Otherwise 3/5 converts to a date and displays as 5-Mar. 

Note:  You can also format cells as fractions (PRIOR to entering data) to allow fractions to 
display correctly. 
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Formatting Multiple Worksheets 

You can format multiple worksheets to have the same formatting and content.  Ungroup 
sheets to enter content specific for each worksheet.   

1. Select the worksheets that you want to be the same. (Hold down the Ctrl key and single 
click all the appropriate worksheet tabs.) 

2. Enter all data and apply all formatting, that you want to display on all the selected 
worksheets. Each sheet will display the identical data and formatting. 

Tip:  Group worksheets before creating Headers and/or Footers in large workbooks. 

Adding Data Specific for Each Worksheet 

When you are ready to add the data specific for each sheet, be sure to ungroup the 
worksheets.  To ungroup the worksheets, right-click one of the selected worksheet tabs, then 
select Ungroup Sheets. 

Worksheet Tab Colors 

With Excel 2007 you can now format worksheet tabs.  This is useful for organizing worksheets 
containing related content, similar to the way in which colored file folders are used when 
working with paper files.  To apply a color, right-click the worksheet tab, and select Tab Color.  
Select the desired color, and click OK.   

Quick Data Entry 

You can highlight the cells where you want to enter data to quickly and easily move from cell 
to cell.   

 

Highlight the cells where you want to enter data.  Begin typing the data.  Each time you press 
Enter, the cursor moves to the next cell (down one cell until that column in the highlighted 
area is filled, then to the top highlighted cell in the next column.   This allows efficient use of 
the number keypad.   

Note:  You can also use the Tab key to move left to right within the selected area, then down 
to the next row.   

Note:  To move back one cell press Shift + Enter, or Shift + Tab. 

Tip:  While the cells are still highlighted, apply the desired number formatting. 
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Financial Functions 

Excel has over 300 functions available. These functions perform math, text, logical, and other 
types of calculations. In the Introduction to Excel class we explored some statistical functions.  
We will explore some financial and logical functions in this class. 

Excel’s Financial Terminology 

When you use the Insert Function Wizard, the following terms are described briefly in the 
dialog box.  A more complete description is provided below. 

Present Value (PV) The “principal” amount.  For example, when you invest 
$1000 in a CD, this amount is the principal.  However, if 
you borrow $5,000, this amount is the principal or 
present value of the loan.   

Future Value (FV) Principal amount plus the interest.  If you invest $1,000 
for three years and earn 7% interest, you receive 
$1,225.04 at the end of the three-year term.  This is the 
future value of your investment.    However, if you 
borrow money, the total amount you repay (the principal 
and interest) is the future value.  

Payment (PMT) Can be principal or principal plus interest.  If you deposit 
$100 a month into a savings account, $100 is the 
payment.  If you have a monthly mortgage payment of 
$950, the $950 is comprised of both principal and 
interest. 

Interest Rate (Rate) Percentage of the principal, usually expressed on an 
annual basis.  It may be necessary to divide by months 
or quarters to get a correct result.   

Period Represents when the interest is paid or earned.  A bank 
CD may pay interest quarterly; a car loan may require 
monthly interest payments.  

Term Amount of time of interest.   

NPER Number of payment periods. 
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PMT Function 

You can have Excel calculate payments, as well as interest, and principle. 

1. Select the cell where you want to display the result of the function. 

2. Click the Insert Function button (from the Formulas tab OR from the Formula bar.   

 

or 

For Financial Functions, click Financial from the Formula tab to display a list of Financial 
Functions.   

3. From the Select a function: field, select the appropriate function.  For the Payment function, 
select Financial, then select PMT.  

  

 To calculate payments, select PMT 

 To calculate interest, select IPMT 

 To calculate principle, select PPMT 

Note:  If you enter the PMT function manually, it will display as follows:   
=PMT(rate,nper,pv,fv,type) 

Description 
of selected 
function 

You can also type 
search text and click 
Go to locate a 
function. 
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4. Click OK to close the dialog box. The Formula Arguments palette displays. The example 
below is for the PMT function. 

  

5. Complete the Formula Arguments palette by typing the appropriate information or 
clicking the appropriate cells with the mouse.   

Hint: You can drag the Formula Pallet out of your way or click the Collapse button  to 

collapse the dialog box and select the appropriate cells. If you clicked , press Enter to 
return to the Function Arguments dialog box. 

Argument: Description: 

Rate The interest rate per period for the loan. If this is an 
annual interest rate, divide by 12 (/12) to calculate 
monthly payments.  

Nper Total number of payments 

Pv Present value of the loan (how much money is being 
borrowed) 

Fv Future value of the loan – usually 0. (how much money 
is owed at the end of the loan) 

Type Payments are due at the beginning (1) or the end (0) of 
the payment period. 

6. Click OK to close the Function Arguments palette and display the result.  Payment 
results always display as a negative number.  See page 22 for more information. 

 

Description 
of selected 
field 
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Using this example, you can change the interest rate, the loan amount, or the number of 
payments to calculate the payment based upon those variables. 

IPMT & PPMT 

Calculate principle (PPMT) and interest (IPMT) using the above procedures.  IPMT and PPMT 
require entry in another field:  the “Per” field (for what payment do you want to know the 
principle or interest payment).   

Challenge:  You can copy the IPMT function to create an amortization schedule using these 
functions.  This requires using Absolute values.  Absolute cell references are covered in the 
Introduction to Excel class. A brief description is provided below. 

Absolute and Relative Cell References 

By default, when you copy a formula, it calculates relative to its new location. To prevent 
references from adjusting relative to their new location, you can write the formula using 
absolute references to force copied formulas to always use specific cells for some of the cells 
in the formula. 

Absolute References 

To make a cell reference absolute, 
type a $ before the column and row 
references to “lock in” the row and 
column. Example: $B$3 

Note: An easy way to make the cell 
reference absolute is to position the 
cursor in the cell reference in the 
Formula bar, then press F4, then 
press Enter.  

 

 

IPMT Function Copied to Amortization Schedule 
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Negative or Positive Perspective 

Determine the perspective of the owner of the cash flows.  Are you a depositor or the bank?  
Are you the borrower or the lender?   Generally money that comes to you is signed positive.  
Money that goes away from you is signed negative.  So a loan payment you make would be 
negative.  Interest you receive on an investment would be positive.  It may be necessary to 
enter some values of your function as negative numbers to achieve the correct result.    

Rate 7% 

Nper 3 

PMT 0 

PV ($1,000.00) 

Type 0 

FV – Future Value 

Use the future value function to calculate the return on an investment based on periodic, 
constant payments and a constant interest rate.  For instance, you might want to calculate 
how much $1,000 will accumulate to at 7% after 3 years. 

1. Select the cell where you want to display the result of the function. 

2. Click the Insert Function button  on the Formula bar.  

3. From the Select a function: field, select the appropriate function.  For the Future Value 
function, select Financial, then select FV.  

4. Complete the Formula Arguments palette by typing the appropriate information or 
selecting the appropriate cells with the mouse.  

  

5. Click OK to close the Function Arguments palette and display the result.   

If you paid out $1,000 for this 
investment, enter as a 
negative number. 
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Rate  

If you want to determine the rate of growth for an investment, use the Rate function.  For 
instance, you invested $1,000 which has accumulated to $2,000 in 8 years. What was the 
annual growth rate?  An example of data is below.  

Nper 8 

PMT 0 

PV ($1,000.00) 

FV $2,000.00  

Type 0 

1. Select the cell where you want to display the result of the function. 

2. Click the Insert Function button  on the Formula bar.  

3. From the Select a function: field, select the appropriate function.  For the rate function, 
select Financial, then select Rate.  

4. Complete the Formula Arguments palette by typing the appropriate information or 
selecting the appropriate cells with the mouse.  

 

5. Click OK to close the Function Arguments palette and display the result.   
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NPER 

If you want to determine how long it will take to achieve a financial goal based upon a 
constant interest rate, use the NPER function.  For example, if you deposit $100,000 and can 
earn 14% per annum, how long will it take to become a millionaire?  An example of data is 
below. 

Rate 14% 

PMT 0 

PV ($100,000.00) 

FV $1,000,000.00  

Type 0 

1. Select the cell where you want to display the result of the function. 

2. Click the Insert Function button  on the Formula bar.  

3. From the Select a function: field, select the appropriate function.  For the NPER function, 
select Financial, then select NPER.  

4. Complete the Formula Arguments palette by typing the appropriate information or 
selecting the appropriate cells with the mouse.  

 

5. Click OK to close the Function Arguments palette and display the result.   
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Using Logical Functions – IF Statements 

When you use logical functions, you evaluate various conditions to make decisions on 
whether the result of the evaluation is true or false. You can, for example, create a logical IF 
statement to evaluate whether a salesperson has attained their yearly sales quota. You can 
also create a nested If statement to determine the appropriate commission based upon their 
sales. 

If you enter the function manually, the proper syntax for an IF statement is:  
=IF(Logical_text,Value_if_true,Value_if_false)   

You can also use the Insert Function option to complete an IF statement. We will use this 
procedure in this class. 

Logical Test 

The logical test contains a mathematical expression to analyze how one value relates 
to another. An example would be: B6>C6. That condition can be evaluated as either 
true or false. 

Value if True 

When the result of the logical test is true, then the next portion of the equation (the 
Value if true function) executes. This function can calculate a formula, display text, 
such as Increase or Decrease, display a value, or display contents of a cell. 

Value if False 

If the result of the logical test is false, then Excel can perform the same calculations as 
listed above. 

Creating a Simple IF Statement 

We will begin by creating a simple IF statement to see how the Function Wizard helps us to 
assemble the information. 

1. Select the cell where you want the result to display. 
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2. Click Insert Function button  on the Formula bar.   

3. From the Select a function: field, type “IF” in the search bar or select the Logical category, 
and the IF function.  You can also click the Logical category from the Formulas tab and 
select IF.   

4. Click OK. The IF Function Arguments dialog box displays. 

 

5. In the Logical_test field, enter the value you want to test (e.g., C2>B2). 

6. In the Value_if_true field, type the value, word, or cell reference you want to display if the 
logical test is true (e.g., Yes). 

7. In the Value_if_false field, type the value, word, or cell reference you want to display if the 
logical test is false (e.g., No). 

8. Click OK to display the appropriate value in the cell. If appropriate, drag the fill handle to 
copy the formula to adjacent cells. 
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Creating a Nested IF Statement 

If you need to evaluate the information in a more complex manner, you can create a nested IF 
statement. For example, there might be different commission rates awarded, depending upon 
the sales volume. 

A nested IF statement places one IF statement within another. Up to 64 IF statements can be 
nested using Excel 2007.  Previous versions allowed 7 nested conditions.   

To calculate different commissions using a nested IF statement, you might have the following 
criteria. 

 If sales are less than $50,000, the sales person receives a commission  
of 3%. 

 If sales are greater than $100,000, the sales person receives a commission of 10%. 

 If sales are more than $50,000, but less than $100,000, the sales person receives a 
commission of 7%. 

Use the following procedure to create a nested IF statement. 

1. Select the cell where you want to display the result of the formula.  

 

2. Click the Insert Function button  on the Formula bar.) 

3. From the Select a function: field, select the appropriate function.  (Select the Logical 
category, and the IF function.) 

4. Click OK. The IF Function Arguments dialog box displays. 

 

5. In the Logical_test field, enter the value you want to test (e.g., E6<50000).  

Note: Do NOT use commas or $ when entering the numbers in a logical IF statement. 
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6. In the Value_if_true field, type the value, word, or cell reference you want to display if the 
logical test is true (e.g., E6*3%). 

7. In the Value_if_false field, type the formula, value, or text you want to execute or display if 
the logical test is false. In this example, this is the portion that would contain the nested IF 
statement (e.g., for sales less than $50,000). To create the nested IF statement, 

 Click  from the left side of the Formula bar. A new IF function 
box displays and IF( ) displays in the Value_if_false position on the formula bar.  

 In the Logical_test field, enter the expression you want to test (e.g., E6<=80000). 

 In the Value_if_true field, type the formula, value, or text you want to execute or 
display if the logical test is false (e.g. E6*7%). See the example below.  

 In the Value_if_false field, type the formula, value or text you want to execute or 
display if the logical test is true (e.g., E6*10%). 

 

8. Click OK to display the appropriate value in the cell. 

For this example the entire formula would display as follows: 
=IF(E6<50000,E6*0.03,IF(E6<=80000,E6*0.07,E6*0.1)) 

9. If appropriate, use the fill handle to copy the formula to adjacent cells. 
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Working with Comments 

You can add comments to cells in a workbook to help explain information for yourself or for 
others using the workbook. The comments can be printed on the worksheet, at the end of the 
worksheet, or they can just be viewed on line. 

Adding Comments 

Follow these steps to add comments to a worksheet.  

1. Right-click in the cell where you want to insert a comment, and select Insert Comment.   
A text box displays with an arrow pointing to the cell upon which you are commenting.  

2. Type your comment in the box provided. 

 

3. Click outside the comment box to deselect it.  

Viewing Comments 

By default, when you insert a comment on a worksheet, only the comment indicator  
displays in the upper right corner of the cell – not the comment. To view a comment, rest your 
mouse over the cell displaying the comment indicator. 

Displaying an Individual Comment 

1. Right-click on the cell containing the comment indicator. 

2. Select Show / Hide Comment. 
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Displaying or Hiding All Comments on a Worksheet 

Select the Review tab; then select Show All Comments, to toggle between viewing 
and hiding all comments.  This is especially useful if working with a large worksheet 
containing many comments.  If desired, click Previous or Next to navigate from 
comment to comment.   

 

Moving a Comment Box 

If you display a comment, you can click and drag it to a more appropriate location.  

1. Click once on the comment box to display a “fuzzy” border around the box.  

2. Click and drag the border to move the box to the appropriate location. 

Hiding an Individual Comment 

1. Right-click on the cell containing the comment indicator. 

2. Select Hide Comment. 

Editing a Comment 

1. Right-click on the cell containing the comment indicator. 

2. Select Edit Comment. 

3. Make the appropriate changes. 

4. Click outside the comment box. 

Deleting a Comment 

1. Right-click on the cell containing the comment indicator. 

2. Select Delete Comment. 

Changing the Comment Identifier Name 

You can change the name that displays when using a comment.  

1. Click the Microsoft Office button  in the upper-left corner of the Excel screen.  

2. Select Excel Options; then click Popular.   

3. In the User name: field, at the bottom of the dialog box, enter your name. 

4. Click OK. 

Note:  You can also change the name in an individual comment box. 
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Printing Comments 

By default, cell comments and comment indicators don‟t print when you print a worksheet. 
Use the following steps to print comments. 

1. From the Page Layout tab, click the  button from the Page Setup gallery.  The Page 
Setup dialog box displays. 

2. Activate the Sheet tab. 

  

3. In the Comments: area, select the appropriate option. 

 If you select At end of the sheet, all comments print on a separate sheet. The printed 
page contains cell references to indicate to which cells the comments refer. 

 If you select As displayed on sheet, first display the comments, then print.  

4. If desired, click the Print Preview button. 

5. Click Print. 

6. Click OK to close the Page Setup dialog box. 
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Auditing Formulas 

You can use Excel‟s auditing tools to evaluate your formulas. 

The auditing options are available from the Formulas tab.   

 

Precedents and Dependents 

Precedents are the cells referred to by the formula in a given cell. They are the cells upon which 
the data displayed from a formula in a given cell is based.  

Dependents are the cells that contain formulas that refer to a given cell. They are based upon 
the data in the given cell.  

Click in the cell you want to audit; then click Trace Precedents or Trace Dependents to display 
arrows indicating which cells are included or impacted by the formula in the selected cell.   

 To have Excel help with errors, click the Error Checking button. 

 To trace the precedents of a cell move to that cell and click the Trace Precedents button. To 
trace the precedents of the precedents, click the Trace Precedents button more than once.  

 To trace the dependents of a cell move to that cell and click the Trace Dependents button.  
To trace the dependents of the dependents, click the Trace Dependents button more than once. 

 To clear all the arrows, click on the Remove Arrows button. 

Precedent and dependent arrows always show the direction of the dependency. A circle 
marks the precedent cell and the point of the arrow marks the dependent cell.   
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Viewing Cells From Other Worksheets or Workbooks 

If precedents or dependents are cells on another worksheet or workbook, an arrow 
points to a worksheet icon rather than the specific cell. To see the reference of this 
more remote cell, double click on the dotted arrow. 

  

When you double-click the dotted arrow, the Go To dialog box displays indicating 
which cell and worksheet is used in your formula.  Select the cell in the Go to: field, 
then click OK to move to that worksheet and cell.   

 

Troubleshooting Formulas 

When a complex formula does not work, it is useful to troubleshoot the problem by copying 
the formula to a new cell so that you can manipulate the formula without changing the original.  

Copying a Formula to a New Cell While Retaining the Original Formula 

1. Double-click the cell containing the formula. 

2. Press the Home key to go to the beginning of the formula. 

3. Press the space bar or type an apostrophe („). With this as the first character of an 
entry, the entry is converted to text. 

4. Highlight and copy the text entry to a new cell by using Copy and Paste, the fill 
handle, or drag and drop. 

5. Edit the cell containing the formula to remove the space or apostrophe at the 
beginning of the entry to restore the formula. 

Double-click the 
dotted arrow. 
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Cool Tip! 

Copying the Current Value of a Formula to a New Cell 

If you copy data from a formula to another cell, the formula copies by default. 
Therefore, if you change or delete the original data, the resulting data changes or 
displays errors. You might, at times, only want the result of the formula copied to a cell 
– not the actual formula. Follow these steps to copy the formula as a value. 

1. Right-click to select Copy, or press Ctrl + C, or use the copy tool to copy the 
formula into the clipboard. 

2. Right-click to select Paste or press Ctrl + V, or use the paste tool to paste the 
formula   Excel 2007 now displays a palette from which to choose paste options.  
Click the “Palette” button next to the cell to display the following options. 

 

 

Values Only – Pastes the value from the formula in the selected cell.  The value in the 
cell will not update if the formula result changes. 

Link Cells – Pastes a link to the original formula which will update if the formula result 
changes.   

Displaying All Formulas 

To view all formulas on a worksheet, press Ctrl + ~ (upper-left on the keyboard).  

or  

Click  from the Formula tab.   
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Locating and Highlighting Formulas 

You can also locate and select all formulas.  From the Home tab, select Find & Select, 
Formulas.   

 

All formulas on the worksheet display highlighted.  If desired, format the formulas while 
highlighted to easily locate them.  This makes it easy to view formulas to apply 
protection as described earlier in this class, beginning on page 15. 

Hiding Errors in Formulas 

If you have a worksheet that displays errors because not all data is entered in the cells 
referenced in your formulas, you can use 
Conditional Formatting to temporarily hide those 
errors. 

From the Home tab, select Conditional Formatting; 
then click New Rule. 

Enter the information as shown, =ISERROR, with 
the cell reference referring to the cell that contains 
the formula displaying an error (in this case D20). 

Click the Format button and format the font in the 
cell to white.  Note:  You can use the Format painter 
to copy the format to other cells.   
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Circular References 

A circular reference is a reference in a formula that refers directly or indirectly to the cell 
containing that very formula. Most often these references have been accidentally created and 
are an error. One instance when a circular reference is created occurs when someone is 
pointing to other cells while writing a formula. If the writer of the formula incorrectly points back 
to the cell where the formula is to be entered, that reference is added to the formula and the 
formula contains a reference to the cell that contains the formula. Another way a circular 
reference might accidentally be created is by overshooting when selecting a range for a SUM 
or AVERAGE function and selecting the cell containing the function along with the cells that 
contain the data to be summed or averaged. 

If the circular reference is the first circular reference in the worksheet, a dialog box displays as 
a warning. 

 

Click Cancel and change your formulas as necessary.   
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Consolidating Worksheets 

You can use data consolidation to assemble information from supporting worksheets into a 
single master worksheet.  You can consolidate by position or by category. When you 
consolidate, you have a variety of functions available, such as Sum, Average, Max, Min, etc.  

Consolidating by Position 

The simplest way to consolidate is by position.  However, this requires that all supporting 
worksheets have exactly the same layout. 

Follow these steps to consolidate by position. 

1. Activate the worksheet on which you want to consolidate data.   

2. Select the block of cells that will receive the consolidated data. 

 

3. From the Data tab, select Consolidate. The Consolidate dialog box displays. 

 

4. In the Function: field, select the desired function.  For our class, we will select Sum.  
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5. In the Reference: field, enter the appropriate cell references.  The references can be from 
the active workbook or from another workbook. These may be typed in or selected.  When 
consolidating by position, all column and row references are the same, so you should only 
enter the cells containing the actual values that you want to consolidate. 

 If you type in the reference, it must have the following form: 

[Filename]Sheetname!Reference 

If the reference is in the same workbook, the filename is not necessary. 

 To select the reference, click the Collapse Dialog button  and select the 

appropriate worksheet and the appropriate cells. Click  to return to the dialog box. 

6. Click  to add the reference to the dialog box. 

7. Enter the next worksheet and range of cells. 

8. Click  to add the reference to the dialog box. Repeat steps 5-7 until all cell 
references that you want to consolidate have been entered. 

 

9. If you want any changes in the reference sheets to be updated in the consolidated 
worksheet, select Create links to source data.  If this is not selected, only static values 
display which will not be updated. 

10. Click OK. The consolidated values display in the worksheet.   

11. If desired, format the numbers as appropriate. 

Note:  If you selected Create links to source data, Excel displays + and – options to expand 
and collapse information about consolidated source data. 
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Consolidating by Category 

You can also consolidate by category, which is a more useful option.  In our example, we will 
have a different number of stores and different products for which to consolidate sales totals.   

Follow these steps to consolidate by category. 

1. Activate the worksheet on which you want to consolidate data.  The consolidation 
worksheet has no row or column headings. Excel‟s Consolidate command will enter these 
for us. 

2. Select the first cell where you want the consolidated data to display.   

 

3. From the Data tab, select Consolidate. The Consolidate dialog box displays.  

4. Enter the appropriate cell ranges and click Add until ranges are entered.  Be sure to 
include row and column headings in your selection(s). 

5. Select Use labels in Top row and Left column.  

  

6. If you want any changes in the reference sheets to be updated in the consolidated 
worksheet, select Create links to source data. 

7. Click OK to display the consolidated values. 

8. If desired, format the numbers as appropriate. 
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Changing Excel’s Default Settings 

There are many features you can customize in Excel. 
To change these features, click the Office button in the 
upper-left corner of the Excel screen.  At the bottom of 
the menu, select Excel Options. To get help with an 
option, click the  in the upper right corner of the 
dialog box.  

Some example settings are included in this document.  
However, these are personal preferences. 

 

 

Popular Options 

You can set several general options, such as the 
default font, the “user name” and how many worksheets are in new workbooks.  Click the 
Popular link on the left to make your selections; then click OK.   

 



Excel 2007 Intermediate   

42 Copyright © 2007, Carlson School of Management, University of Minnesota 

Using Custom Lists 

You can use Excel‟s default custom lists to quickly enter a series of data in a worksheet, or 
you can create your own.   

Using the Fill Handle 

The fill handle is a very useful tool. It is the lower-right corner of the active cell or of the 
selected range. Dragging the fill handle fills the range across which you drag with the contents 
of the cell. A “fill” command might be nothing more than a copy command, but it can also 
mean that the pattern set by the first entry or entries will be followed in the range to be filled. 

Excel’s Default Custom Lists 

Excel has custom lists for the months of the year and days of the week. For instance, if you 
want to enter all the months as column headings, simply type one month in a cell, then use 
AutoFill to enter the other months. 

1. Select the cell (e.g., January) you want to AutoFill. 

2. Rest your cursor on the “fill handle” of the selected cell. When your mouse pointer displays 

as a cross hair +, proceed to step 3. 

Note: The fill handle is the small box in the lower-right corner of the selected cell. 

3. Click and drag the fill handle in the direction to be filled.  The fill 
handle displays an Auto Fill Options button.  From the drop-down 
list, select the desired option.  To create the list, select Fill Series.  
The default is copy cells, if no other selection is made.  

Creating a New List as an Option for the Fill Handle 

You can also create your own list to fill cells. 

1. Click the Office button  in the upper-left corner of the Excel screen.   

2. At the bottom of the dialog box, select Excel Options. 

3. Select Popular from the left side of the screen; then click the Edit Custom Lists.   
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4. Type the items in the List entries box.  

 

5. Press Enter after each entry.  (You can also use existing entries – see below.) 

6. Click the Add button.   

7. Click OK. 

Using a Range of Existing Entries to Create a New List for the Fill Handle 

1. Click the Collapse button  in the Import list from Cells option to select list entries 
from a range of entries in a sheet. 

2. Select the range. 

3. Click  to expand the dialog box. 

4. Click Import. 

5. Click OK. 
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Using the Fill Handle with a Range as the Pattern 

A range can be used as the pattern for the fill to copy more than one cell or to fill a 
range with numbers that vary by a certain interval. Two cells are selected as the 
pattern for the fill command so that the interval is specified. 

1. Select the range to be used as the pattern you want to fill.  

2. Rest your cursor on the “fill handle” of the selected cell. When your mouse pointer 

displays as a cross hair +, proceed to step 3. 

3. Click and drag the fill handle in the direction to be filled. 

 

4. Select Fill Series, to fill in the desired pattern.   

Note: Dragging up or to the left fills “backwards.” 

Default “Save As” Option 

Because the Excel 2007 file type is an XML file, not all users who have previous versions will 
be able to open your workbooks.  You may want to change the default Save As option to 
Excel 97 – 2003 by selecting the option from the Save files in this format drop-down box. 

  

Course Practice File 

You can access the practice file for this course from www.carlsonschool.umn.edu/oittraining.  
Click the link for Microsoft Excel 2007 - Intermediate; then click the Practice file link.   

http://www.carlsonschool.umn.edu/oittraining

